【已解决】ubuntu16.04和Python3.5里的大坑

【已解决】ubuntu16.04和Python3.5里的大坑

因为一些历史原因,几个服务器的系统都一直是ubuntu16.04,ubuntu16.04的python3的默认版本是3.5。

而我这次配置python环境需要用到Pymysql

配置成功后,然后直接运行,一直报错。我还一直尝试修改pymysql的代码,一度以为镜像站里的pymysql有错误。

甚至跑去GitHub中找到https://github.com/PyMySQL/PyMySQLhttps://github.com/PyMySQL/PyMySQL 找到PyMsql的代码,去手动安装。

最后在GitHub的文档中发现。

Python — one of the following:

好家伙,需要python3.6以上的版本才可以运行。

然后就需要安装python3.6,

可谁又能想到,ubuntu16.04安装Python3.6又有一个大坑!!!

ubuntu16.04默认的软件repository中并不包含python3.6(最高到python3.5),所以无法通过下面命令直接安装python3.6

apt-get install python3.6

当你强制执行上述命令是会出现如下错误:

E: Unable to locate package python3.6-dev
E: Couldn't find any package by glob 'python3.6-dev'
E: Couldn't find any package by regex 'python3.6-dev'

因此,需要先添加repository库

sudo add-apt-repository ppa:deadsnakes/ppa

再进行apt install python3.6 等操作即可。

python3.6安装完成后,直接执行python3会首先调用python3.5版本。因此我们还需要

调整Python3的优先级,使得3.6优先级较高

发表评论